FÓRMULAS DE EXCEL

Contar celdas con rangos no contiguos en Excel

Contar celdas con rangos no contiguos en Excel

Funciones utilizadas: SUMA, CONTAR.SI. INDIRECTO

Suponiendo que disponemos de tres rangos distintos y no contiguos con encabezados en B4:B10, D9:D19 y F6:F11, y que necesitamos obtener en la celda K4 la cantidad de celdas de los tres rangos que sean mayores a 70, podemos utilizar un método simple y efectivo para resolverlo:

MÉTODO TEXTO A RANGOS CON INDIRECTO

La sintaxis que debemos aplicar en la celda K4 es la siguiente:

=SUMA(CONTAR.SI(INDIRECTO({"B5:B10""D10:D19""F7:F11"});">70"))

Donde B5:B10, D10:D19 y F7:F11 corresponden a los tres rangos no contiguos y sin encabezados a analizar.

Debido a que la función CONTAR.SI no admite múltiples rangos como argumento, escribimos los rangos como texto en una matriz constante dentro de la función INDIRECTO. De esta forma forzamos a que la función CONTAR.SI reciba más de un rango, devolviendo un resultado de matriz que lo capturamos con la función SUMA.

De esta forma, logramos obtener para un rango fijo, no contiguo y de valores similares, la cantidad de celdas que cumplen una determinada condición.

Puedes conocer más métodos de búsqueda y referencia de celdas en el Anuario de Desafiando Excel.

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores.