Icono del sitio Desafiando Excel

Contar celdas de una lista dentro de un rango

Funciones utilizadas: SUMAPRODUCTO, CONTAR.SI

 

Podemos utilizar la siguiente fórmula para contabilizar la cantidad de celdas que poseen alguno de los valores de nuestro listado de referencia:

=SUMAPRODUCTO(CONTAR.SI(C4:C6;A2:A20))

 

Reemplazar el rango C4:C6 dentro de la sintaxis por el rango requerido correspondiente al listado de referencia, y reemplazar el rango A2:A20 con el total de la lista de la cual debemos buscar valores dentro.

Esta fórmula es súmamente útil dado que resume en un sólo cálculo variables que de otra forma deberíamos obtener mediante fórmulas intermedias.

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores. 

Salir de la versión móvil