FÓRMULAS DE EXCEL

Contar celdas distintas de una lista en Excel

Contar celdas distintas de una lista en Excel

Funciones utilizadas: SUMAPRODUCTO, ESNOD, COINCIDIR

Suponiendo un rango de nombres en A1:A20 y un rango auxiliar con nombres en C4:C6, quisiéramos averiguar cuantos nombres distintos del rango C4:C6 hay en el rango A1:A20. Para ello utilizamos la siguiente sintaxis:

=SUMAPRODUCTO(--(ESNOD(COINCIDIR(A1:A20;C4:C6;0))))

Donde A1:A20 corresponde al rango original que necesitamos evaluar, y C4:C6 corresponde al rango con nombres que necesitamos identificar dentro del rango A1:A20 para poder contar aquellos valores distintos.

Lo que buscamos es sumar los «VERDADERO» convertidos a 1 por el operador «–«, que son aquellos valores no disponibles «#N/D» de la función COINCIDIR convertidos a «VERDADERO» por la función ESNOD.

Si necesitamos calcular la cantidad de celdas que NO CONTENGAN ALGUNA PALABRA de un rango, podemos utilizar la fórmula del siguiente artículo: Contar celdas que no contengan alguna palabra en Excel

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores.