FÓRMULAS DE EXCEL

Contar celdas que empiezan igual en Excel

Contar celdas que empiezan igual en Excel

Funciones utilizadas: SUMAPRODUCTO, IZQUIERDA

Suponiendo que disponemos de un listado de códigos con encabezado en el rango A1:A16 y una celda de referencia de búsqueda en F2, podemos aplicar una fórmula que nos permite obtener el número de celdas del rango objetivo que empiezan con los caracteres definidos en la celda F2. La sintaxis que debemos colocar en una celda destino es la siguiente:

=SUMAPRODUCTO(--(IZQUIERDA(A2:A16;2)=F2))

Donde A2:A16 es el rango objetivo sin encabezado donde buscaremos los valores que cumplan con la condición, «2» es el número de caracteres que analizaremos desde la izquierda y por celda del rango objetivo, F2 es la celda que define los caracteres a buscar al inicio (izquierda) de cada celda del rango objetivo.

La fórmula combina las funciones SUMAPRODUCTO e IZQUIERDA para lograr contabilizar las celdas que cumplen con el criterio dado. Internamente, la función IZQUIERDA nos devuelve una matriz con todos los dos primeros números del rango objetivo, para que luego comparemos cada valor de la matriz igualándolo con el valor en la celda F2, lo que nos devolverá una nueva matriz de VERDADEROS y FALSOS. Finalmente, convertimos los VERDADEROS y FALSOS a «1» y «0» mediante el doble operador «-» para que la función SUMAPRODUCTO cuente los valores «1» que son aquellos valores correctos para contabilizar.

De esta forma, logramos obtener una fórmula que nos cuenta las celdas de un rango definido que empiezan con «n» valores objetivo de forma simple y rápida.

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores.