Desafiando Excel

Contar el número de veces que se repiten dos celdas por fila o columna

Funciones utilizadas: SUMAPRODUCTO, SUMA

 

Contar repeticiones por fila

Existen distintas alternativas para lograr contabilizar las coincidencias entre dos rangos por filas:

=SUMAPRODUCTO((A1:A10=B1:B10)*1)
=SUMAPRODUCTO(--(A1:A10=B1:B10))
{=SUMA((A1:A10=B1:B10)*1)}
=SUMAPRODUCTO((A:A=B:B)*(B:B<>""))

 

Aplicaremos estas fórmulas para el rango A1:A10 y B1:B10, a excepción de la última fórmula que es aplicable a toda la columna de A y B sin contabilizar las repeticiones de vacíos.

 

Contar repeticiones por columna

Existen distintas alternativas para lograr contabilizar las coincidencias entre dos rangos por columnas:

=SUMAPRODUCTO((A1:J1=A2:J2)*1)
=SUMAPRODUCTO(--(A1:J1=A2:J2))
{=SUMA((A1:J1=A2:J2)*1)}
=SUMAPRODUCTO((1:1=2:2)*(2:2<>""))

 

Aplicaremos estas fórmulas para el rango A1:J1 y A2:J2, a excepción de la última fórmula que es aplicable a toda la fila 1 y 2 sin contabilizar las repeticiones de vacíos.

 

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores. 

Salir de la versión móvil