Icono del sitio Desafiando Excel

Contar los valores únicos de un rango de valores

Funciones utilizadas: SUMAPRODUCTO, CONTAR.SI, SUMA, SI, ESBLANCO, FRECUENCIA, COINCIDIR, FILA

 

Especificaremos las fórmulas para contar valores únicos de un rango en función de si el rango posee o no celdas vacías:

Contar valores únicos en rangos con celdas vacías

Podemos utilizar una de las siguientes fórmulas para contar valores únicos de un rango de valores donde los valores repetidos se cuentan una sola vez, y dicho rango puede contener o no celdas vacías:

=SUMAPRODUCTO((A2:A20<>"")/CONTAR.SI(A2:A20;A2:A20&""))
{=SUMA((A2:A20<>"")/CONTAR.SI(A2:A20;A2:A20&""))}
{=SUMA(SI(ESBLANCO(A2:A20);0;1/CONTAR.SI(A2:A20;A2:A20)))}

Reemplazar el rango A2:A20 dentro de la sintaxis por el rango requerido.

 

Contar valores únicos en rangos sin celdas vacías

Podemos utilizar una de las siguientes fórmulas para contar valores únicos de un rango de valores donde los valores repetidos se cuentan una sola vez, y dicho rango no debe contener celdas vacías:

=SUMAPRODUCTO(1/CONTAR.SI(A2:A20;A2:A20))
=SUMAPRODUCTO(--(FRECUENCIA(COINCIDIR(A2:A20;A2:A20;0);FILA(A2:A20)-FILA(A2)+1)>0))

Reemplazar el rango A2:A20 dentro de la sintaxis por el rango requerido.

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores. 

Salir de la versión móvil