Icono del sitio Desafiando Excel

Eliminar los valores de una celda a partir de un carácter

Funciones utilizadas: LARGO, SUSTITUIR, EXTRAE, ENCONTRAR

 

=SI(LARGO(A1)-LARGO(SUSTITUIR(A1;"X";""))<>1;A1;EXTRAE(A1;1;ENCONTRAR("X";A1;1)-1))

Donde “X” es el carácter a hallar y “-1” indica que excluimos el carácter hallado. En caso de que queramos incluir este carácter debemos eliminar el “-1” de la sintaxis.

Está fórmula cumple un objetivo similar a la fórmula de extraer valores de una celda hasta hallar un carácter o palabra, pero es más limitada. Sólo sirve para hallar caracteres individuales y no debe estar repetido dentro de la celda.

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores. 

Salir de la versión móvil