Desafiando Excel

Extraer la celda más larga en Excel

Funciones utilizadas: INDICE, COINCIDIR, MAX, LARGO

Suponiendo que disponemos de un listado con distintos valores de texto y/o números en el rango A2:A20 y que necesitamos obtener en la celda C3 el valor más largo (es decir con mayor cantidad de caracteres) del rango objetivo, podemos utilizar un método simple y efectivo para resolverlo:

MÉTODO INDICE Y COINCIDIR

La sintaxis que debemos aplicar en la celda C3 es la siguiente:

{=INDICE(A2:A10;COINCIDIR(MAX(LARGO(A2:A10));LARGO(A2:A10);0))}

Donde A2:A10 corresponde al rango objetivo de celdas a analizar.

La fórmula parte de obtener con la función LARGO una matriz con todas las cantidades de caracteres por celda del rango objetivo. Luego aplicamos la función MAX para obtener el valor más alto de dicho rango y la función COINCIDIR para devolver la posición de dicho valor más alto dentro de la matriz. Finalmente la función INDICE devuelve el valor correcto para los ejes definidos.

De esta forma, logramos obtener de forma rápida y práctica el valor más largo de un rango de celdas objetivo.

Puedes conocer más métodos de extracción de celdas y valores en el Anuario de Desafiando Excel.

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores. 

Salir de la versión móvil