Icono del sitio Desafiando Excel

Hallar si se repite un patrón de un conjunto de celdas por fila

Funciones utilizadas: SUMAPRODUCTO

 

Suponiendo que nuestra matriz está en el rango A1:C6. Colocamos la siguiente fórmula en fila 1 de una columna vacía y arrastramos hacia abajo hasta la última fila a analizar:

=SUMAPRODUCTO(($A$1:$A$6&$B$1:$B$6&$C$1:$C$6=$A1&$B1&$C1)*1)

Cada valor de resultado devuelve el número de veces que se repite el patrón de celdas en el rango de filas.

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores. 

Salir de la versión móvil