FÓRMULAS DE EXCEL

Promediar cada N filas o columnas

Promediar cada N filas o columnas

Funciones utilizadas: PROMEDIO, SI, RESIDUO

 

Suponiendo un rango de valores en A1:A20 y la celda D2 que define cada cuantas filas debemos considerar dichos valores, podemos calcular el promedio general utilizando la siguiente fórmula:

{=PROMEDIO(SI(RESIDUO(rango;D2)=0;rango))}

 

Donde «rango» es el nombre que le asignamos al rango de valores, y D2 es la celda «N» objetivo.

Esta fórmula puede aplicarse del mismo modo a columnas, por ejemplo suponiendo un rango de valores en A1:T1 denominado «rango2» y la celda A3 que define cada cuantas columnas debemos considerar dichos valores, la fórmula será la siguiente:

{=PROMEDIO(SI(RESIDUO(rango2;A3)=0;rango2))}

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores.