FÓRMULAS DE EXCEL

Sumar celdas en función del inicio o fin de una celda

Sumar celdas en función del inicio o fin de una celda

Funciones utilizadas: SUMAR.SI

Suponiendo un rango de valores en A2:C20, donde la columna A contiene números de pedidos (no significativo para el análisis), la columna B contiene los productos vendidos con el detalle de las características separadas por comas, y donde la columna C contiene los importes de venta , podemos calcular la suma de importes en función de los primeros o últimos caracteres de la columna B mediante una de las siguientes fórmulas:

SUMAR DESDE EL INICIO DE UNA CELDA

=SUMAR.SI(B2:B20;"Mesa*";C2:C20)

Donde «B2:B20» corresponde al rango de los textos a buscar desde el inicio, «Mesa*» corresponde a la palabra a buscar desde el inicio, y «C2:C20» corresponde al rango de importes a sumar en función de las celdas paralelas que contengan al inicio «Mesa».

SUMAR DESDE EL FIN DE UNA CELDA

=SUMAR.SI(B2:B20;"*blanco";C2:C20)

Donde «B2:B20» corresponde al rango de los textos a buscar desde el final, «*blanco» corresponde a la palabra a buscar desde el final, y «C2:C20» corresponde al rango de importes a sumar en función de las celdas paralelas que contengan al final «blanco».

Podemos resumir entonces que si necesitamos buscar desde el inicio de una celda debemos colocar el símbolo asterisco luego de la palabra deseada, y si necesitamos buscar desde el final de una celda debemos colocar el símbolo asterisco antes de la palabra deseada.

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores.