Desafiando Excel

Sumar los valores únicos de un rango de valores

Funciones utilizadas: SUMAPRODUCTO, CONTAR.SI, SUMA

 

Podemos utilizar una de las siguientes fórmulas para sumar valores únicos de un rango de valores donde los valores repetidos se suman una sola vez:

=SUMAPRODUCTO(A1:A10/CONTAR.SI(A1:A10;A1:A10))
{=SUMA(A1:A10/CONTAR.SI(A1:A10;A1:A10))}

 

Reemplazar el rango A1:A10 dentro de la sintaxis por el rango requerido.

El rango no puede tener celdas vacías y debe contener sólo valores numéricos.

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores. 

Salir de la versión móvil