FÓRMULAS DE EXCEL

Sumar por semana en Excel

Sumar por semana en Excel

Funciones utilizadas: SUMAR.SI.CONJUNTO

Suponiendo que disponemos de un rango de fechas e importes para un mes con encabezado en el rango A1:B20, y que necesitamos obtener en el rango E4:E7 la suma total de dichos importes para cada semana por separado contabilizando cada semana de lunes a domingo, podemos utilizar el siguiente método para obtenerlo:


SUMAR POR SEMANA EN EXCEL

1)  El primer paso consiste en crear una lista paralela al rango de resultados de E4:E7 con la fecha del primer dia de cada semana a contabilizar. En el video utilizamos el rango D4:D7 y colocamos las fechas que corresponden a cada dia lunes del mes a analizar (ya que contabilizaremos cada semana de lunes a domingo).

2) Luego debemos nombrar a cada rango de datos del listado original sin encabezados, en este caso nombramos «fechas» al rango de fechas en A2:A20 e «importes» al rango de importes en B2:B20.

3) Colocamos la siguiente sintaxis en la celda E4 y arrastramos hacia abajo hasta E7:

=SUMAR.SI.CONJUNTO(importes;fechas;">="&D4;fechas;"<"&D4+7)

 

De esta forma, logramos sumar los importes de cada semana de un rango original de forma simple y rápida en Excel.

Puedes encontrar más formas simples y efectivas de sumar y contar en Excel en el ebook gratuito (freebook) disponible en la tienda.

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores.