FÓRMULAS DE EXCEL

Validar celdas con MARCAS DE VERIFICACIÓN en Excel

Validar celdas con MARCAS DE VERIFICACIÓN en Excel

Funciones utilizadas: SI, CONTAR.SI

Suponiendo un rango con nombres de productos (A2:A10), un rango dinámico con los nombres de productos actuales en stock (E2:E10), planteamos el siguiente método en el rango B2:B10 para validar el stock de los productos del rango de la columna A con marcas de verificación:


VALIDAR CELDAS CON MARCAS DE VERIFICACIÓN EN EXCEL

=SI(CONTAR.SI($E$2:$E$10;A2);"P";"")

Donde “$E$2:$E$10” corresponde al rango dinámico con los productos actuales en stock y “A2” corresponde a la celda con el primer nombre de producto. Fórmula a aplicarse en la celda B2 y arrastrar hasta B10.

Combinamos las funciones SI y CONTAR.SI para obtener el resultado deseado.

Utilizamos el condicional “SI” para comprobar una expresión lógica con la función CONTAR.SI, donde de cumplirse devolverá la letra mayuscula “P”, caso contrario devolverá vacío.

La función CONTAR.SI comprueba si el valor en A2 (primer producto) aparece en el rango dinámico de stock, devolviendo “1” si se encuentra y “0” si no lo encuentra.

Finalmente, utilizamos la letra mayúscula “P” como resultado válido de la función SI debido a que al modificar la fuente en el rango resultado (B2:B10) por la fuente “Wingdings 2”, convertiremos la letra “P” en el símbolo de checkmark o marca de verificación.

De esta forma logramos validar celdas con marcas de verificación en base a un rango dinámico dentro de una hoja en Excel.

Puedes encontrar más fórmulas interesantes en el anuario de Desafiando Excel en el siguiente link.

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores.