FUNCIONES DE EXCEL

Función BUSCARV en Excel

Función BUSCARV en Excel

Funciones en este artículo: BUSCARV

SINTAXIS DE LA FUNCIÓN BUSCARV: =BUSCARV(VALOR_BUSCADO;MATRIZ_BUSCAR_EN;INDICADOR_COLUMNAS;ORDENADO)

La función BUSCARV busca un valor en la primera columna de la izquierda de una tabla y luego devuelve un valor en la misma fila desde una columna especificada.

Los argumentos de la función son:

VALOR_BUSCADO: Es el valor del cual va a depender toda la función. Debe estar en la primera columna de la tabla y puede ser un número, una referencia a otra celda (buscarv indirecto) o bien una cadena de texto.

MATRIZ_BUSCAR_EN: Es la tabla de la cual se buscarán los datos. Puede ser una referencia o también un nombre de rango, es decir puede ser por ej. A1:B4 o bien «lista» denominando a ese rango.

INDICADOR_COLUMNAS: Es el número de columna de la matriz desde la cual debe devolverse el valor que coincida con la fila del valor buscado. La primer columna de la tabla siempre será la columna 1 a fin de determinar cuál columna necesitamos para recuperar el valor deseado.

ORDENADO: Es un valor lógico. Permite determinar si lo que deseamos encontrar es la coincidencia más cercana en la primera columna (VERDADERO o uno), o bien encontrar la coincidencia exacta (FALSO o cero). Normalmente se suele utilizar el valor exacto para referenciar, con lo cual deberemos colocar FALSO o cero.

Veamos unos ejemplos para comprender mejor esta función:

1. Si tuviésemos los siguientes datos en una tabla en el rango A1:D4,

NombreApellidoEdadEstado Civíl
PedroGutierrez42Casado
ClaudiaGómez35Soltera
DiegoVega28Soltero

 

y quisieramos que en la celda E1 nos devuelva la edad de «Claudia», podríamos utilizar la función BUSCARV con la siguiente sintaxis:

=BUSCARV(A3;A1:D4;3;0)

 

En otras palabras, le pedimos a Excel que nos busque el valor exacto de A3, dentro del rango A1:D4, y que nos devuelva el valor de la tercer columna (edad) según dicha fila. Esta es una búsqueda directa con BUSCARV. También podríamos buscar dentro del rango A:D directamente ya que no tenemos otros valores en dichas columnas, caso contrario debemos siempre especificar el rango preciso de nuestra tabla.

Es muy importante aclarar que la función BUSCARV busca, encuentra y referencia sobre el primer valor encontrado, en nuestro caso realiza el cálculo basándose en la primer «Claudia» que encuentra de la columna A de arriba hacia abajo. Como nuestro listado de la columna A no tiene otras celdas con el contenido «Claudia», no tenemos inconveniente en encontrar su edad. Pero si lo que deseamos es encontrar una celda «Claudia» que no es la primera celda encontrada de la columna de arriba hacia abajo debido a que está repetido dicho nombre, debemos utilizar otras fórmulas y métodos menos convencionales.  AQUÍ tienes un video con una opción para resolverlo con macros si estás necesitando dicha solución.

Del mismo modo, si el VALOR_BUSCADO en vez de ser la celda directa de la tabla de la cual buscamos su referencia, fuese otra celda por fuera de la tabla, estaríamos utilizando una búsqueda indirecta con BUSCARV. Basándonos en nuestro ejemplo anterior, en vez de ser «A3» que está dentro de la tabla con el valor buscado, podríamos poner «F1» y que en la celda F1 haya una lista desplegable de todos los nombres de la tabla, y de esta forma podemos ir cambiando el valor en «E1» dando como resultado búsquedas distintas por cada nombre.

 

Te recomiendo ver el siguiente link con más videos de Funciones básicas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores.