TUTORIALES DE EXCEL

C贸mo combinar dos listas en Excel

C贸mo combinar dos listas en Excel

驴C贸mo combinar dos listas en Excel?

En el video tutorial ejemplificamos como podemos combinar dos listas de forma aleatoria en Excel, donde cada valor del rango 1 se vincula con un valor del rango 2 sin repetici贸n alguna.

Los pasos a seguir son los siguientes:

    1. Suponiendo un rango de nombres de hombres en B2:B11 y un rango de mujeres en C2:C11, vamos a generar una serie num茅rica del 1 al 10 en el rango A2:A11.
    2. En el rango E2:F11 aplicamos la funci贸n ALEATORIO() a todo los valores. De esta forma asumiremos que cada valor aleatorio se vincula a un nombre bas谩ndonos en el mismo rango pero de las columnas B y C.
    3. El tercer paso ser谩 jerarquizar del 1 al 10 cada valor aleatorio por columna para los rangos de las columnas E y F. Aplicaremos una f贸rmula en el rango H2:I11 que nos permite ordenar cada valor aleatorio del 1 al 10, donde el valor m谩s cercano a 1 del resultado de la funci贸n ALEATORIO() ser谩 el 1 y el valor m谩s cercano al 0 de la funci贸n ALEATORIO() ser谩 el 10. La sintaxis en la celda H2 es la siguiente debiendo arrastrar la f贸rmula hasta la celda H11: =JERARQUIA(E2;$E$2:$E$11)+CONTAR.SI($E$2:E2;E2)-1
      Del mismo modo, aplicamos la siguiente sintaxis en la celda I2 debiendo arrastrar la f贸rmula hasta la celda I11: =JERARQUIA(F2;$F$2:$F$11)+CONTAR.SI($F$2:F2;F2)-1
    4. Finalmente utilizamos el rango K2:L11 para devolver el nombre que le corresponde a cada valor jer谩rquico que parte de un valor aleatorio por columna vinculada (hombres y mujeres). Para esta referencia podemos utilizar dos m茅todos, por un lado la combinaci贸n de las funciones INDICE+COINCIDIR, o bien la funci贸n BUSCARV. En el video se explican ambos m茅todos, utilizando el primer m茅todo para obtener los nombres de hombres, y el segundo m茅todo para obtener los nombres de mujeres. La sintaxis en la celda K2 es la siguiente debiendo arrastrar la f贸rmula hasta la celda K11: =INDICE($B$2:$C$11;COINCIDIR(H2;$A$2:$A$11;0);COINCIDIR($B$1;$B$1:$C$1;0))
      Por otro lado, la sintaxis en la celda L2 de la funci贸n utilizada para obtener los nombres de mujeres es la siguiente debiendo arrastrar la funci贸n hasta la celda L11: =BUSCARV(I2;A:C;3;0)

De esta forma logramos obtener combinaciones aleatorias sin repetici贸n de valores entre dos listas con mismo n煤mero de valores por rango.

 

Te recomiendo ver el siguiente link con m谩s videos de Tutoriales esenciales de Excel聽AQU脥.

Salvo aclaraci贸n, todas las f贸rmulas y macros de este sitio est谩n configuradas para aplicarse sobre la celda A1.聽Algunas f贸rmulas se encuentran encerradas entre llaves {} debido a que son f贸rmulas matriciales. Estas llaves no deben introducirse tecle谩ndolas, sino que se generan autom谩ticamente al aceptar la f贸rmula pulsando Control+Shift+Enter al mismo tiempo.聽Las f贸rmulas de este sitio son compatibles con versiones de Microsoft Excel庐 2010 o superiores.聽