FÓRMULAS DE EXCEL

Contar filas con condiciones en Excel

Contar filas con condiciones en Excel

Funciones utilizadas: SUMAPRODUCTO

Suponiendo que disponemos de una lista con encabezados en el rango A1:C10, donde el rango A2:A10 contiene nombres de distintos productos, el rango B2:B10 tiene importes de facturación para un primer mes, y el rango C2:C10 tiene importes de facturación para un segundo mes, y que necesitamos obtener en las celdas F3 y F4 la cantidad de filas del rango B2:C10 que tuvieron un aumento de importes y una disminución de importes respectivamente, podemos aplicar una fórmula que combina la función SUMAPRODUCTO con el doble operador «–» para lograr obtener la cantidad de filas que cumplen con la condición dada. La sintaxis que debemos utilizar para obtener la cantidad de productos con aumento de facturación es la siguiente:

=SUMAPRODUCTO(--(B2:B10<C2:C10))

Donde B2:B10 corresponde al rango de importes del primer mes, y C2:C10 corresponde al rango de importes del segundo mes.

El operador «–» permite convertir los valores lógicos VERDADERO y FALSO de la matriz que creemos a valores numéricos de 1 y 0 respectivamente, para luego poder sumar con la función SUMAPRODUCTO aquellos valores que cumplen con la condición (los valores «1»). En este caso, por cada fila donde el valor de la columna B sea menor al valor de la columna C, la fórmula sumará 1 ya que son considerados productos con aumento (B<C).

Para obtener la cantidad de productos con disminución debemos simplemente invertir el signo «menor que» por «mayor que» dentro de la sintaxis. De esta forma, por cada fila donde el valor de la columna B sea mayor al valor de la columna C, la fórmula sumará 1 ya que son considerados productos con disminución (B>C)

De esta forma, logramos obtener de forma rápida y simple la cantidad de filas que cumplen con una condición específica dentro de un rango en Excel.

Si necesitas contar filas con más de una condición te recomiendo ver el siguiente video: Contar filas con condiciones múltiples en Excel

 

Te recomiendo ver el siguiente link con más videos de Fórmulas ingeniosas de Excel AQUÍ.

Salvo aclaración, todas las fórmulas y macros de este sitio están configuradas para aplicarse sobre la celda A1. Algunas fórmulas se encuentran encerradas entre llaves {} debido a que son fórmulas matriciales. Estas llaves no deben introducirse tecleándolas, sino que se generan automáticamente al aceptar la fórmula pulsando Control+Shift+Enter al mismo tiempo. Las fórmulas de este sitio son compatibles con versiones de Microsoft Excel® 2010 o superiores.